В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Nurbakyt2103
Nurbakyt2103
26.05.2021 02:30 •  Информатика

1.cоставить программу,которая заполняет квадратную матрицу 9 х 9. 1 1 1 1 2 2 2 3 3 3 9 9 9 2.составить программу решения поставленной . в прямоугольной матрице отрицательные числа заменить им противоположными.

Ответ:
Сmetana34
Сmetana34
06.10.2020 04:21
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrGen(9,9,(i,j)->i+1); a.Println(2);
end.

Результат
 1 1 1 1 1 1 1 1 1
 2 2 2 2 2 2 2 2 2
 3 3 3 3 3 3 3 3 3
 4 4 4 4 4 4 4 4 4
 5 5 5 5 5 5 5 5 5
 6 6 6 6 6 6 6 6 6
 7 7 7 7 7 7 7 7 7
 8 8 8 8 8 8 8 8 8
 9 9 9 9 9 9 9 9 9

begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в матрице:');
  Writeln('*** Исходная матрица [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  Writeln('*** Результат [',n,',',m,'] ***');
  a.Fill((i,j)->Abs(a[i,j])); a.Println(4)
end.

Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 7
*** Исходная матрица [4,7] ***
  10  42   3  83 -65  43  65
 -52 -40  55  75 -27  53 -47
  17  88  93  32  35  41 -76
  70  13   6   2   9 -22 -55

*** Результат [4,7] ***
  10  42   3  83  65  43  65
  52  40  55  75  27  53  47
  17  88  93  32  35  41  76
  70  13   6   2   9  22  55
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?