Войти
Регистрация
Спроси ai-bota
В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Показать больше
Показать меньше
ИришкаTV
05.03.2021 08:30 •
Информатика
Создайте программу, которая запрашивает значения 5 переменных и организует циклический обмен. a1< -a2,a2< -a3..a5< -a1. пример: 1 2 3 4 5. после обмена: 2 3 4 5 1
Ответ:
Черныйкотик007896
06.10.2020 03:47
Var
a1,a2,a3,a4,a5,B:real;
Begin
Write('Введите пять чисел: ');
ReadLn(a1,a2,a3,a4,a5);
B:=a1;
a1:=a2;
a2:=a3;
a3:=a4;
a4:=a5;
a5:=B;
WriteLn(a1,' ',a2,' ',a3,' ',a4,' ',a5);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Азрет2002
29.05.2022 19:34
Дана строка символов. определить число символов в строке. если это число меньше 10, то добавить к строке символы клмнопрст .нужен паскаль...
Бигль02
29.05.2022 19:34
1.составить программу, которая переводит биты в кбайты....
KIA79
29.05.2022 19:34
Какое минимальное основание имеет система счисления, если в ней записаны числа 127,222,111?...
zhezhuzina2006
29.05.2022 19:34
Через некоторое соединение со скоростью 3 кбайта в секунду в течение 10 секунд передаётся файл. определите время(в секундах) передачи этого же файла через другое соединение...
743Slivka
29.05.2022 19:34
Вспомни и запиши как можно больше имён героев и названий предметов из сказок, которые 1) имеют необычный рост 2) имеют необычное количество частей 3) сделаны из необычного...
Nazarkadm
07.06.2023 03:10
Составьте программу (блок схема и на паскаль) нахождения площади треугольника по формуле герона если извесны все три стороны...
verik2643
25.07.2020 14:41
Напишите программу: вася обычно спит ночью x часов и устраивает себе днем тихий час на y минут. определите, сколько всего минут вася спит в сутки. внимание, программа принимает...
artem7859
28.03.2022 03:13
Написать программу получения целых случайных чисел из интервала (-3; 70) признак окончания-полученное число 5. определить сколько получено чисел которые делятся на 3. сделайте...
NAPAS228
17.09.2020 14:05
Нужно построить дерево граф для арифметического выражения 6x4+7x(9-1). заранее ....
Puroscok009
17.09.2020 14:05
Написать скрипт в котором пользователь вводит номер месяца в году (1 - январь, 2 - февраль и т.д.) а на экран выводится время года. в программе python...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a1,a2,a3,a4,a5,B:real;
Begin
Write('Введите пять чисел: ');
ReadLn(a1,a2,a3,a4,a5);
B:=a1;
a1:=a2;
a2:=a3;
a3:=a4;
a4:=a5;
a5:=B;
WriteLn(a1,' ',a2,' ',a3,' ',a4,' ',a5);
End.