В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Лера565009
Лера565009
08.04.2020 04:50 •  Информатика

Написать программу.(информатика) 1)элементы заданного массива x = (x1 , x2, ) переупорядочите следующим образом: x = (xn , xn-1 , x1 ).

Ответ:
мurr
мurr
06.10.2020 03:30
Var i,n,k: integer;
    a: array[1..100] of integer;
begin
  write('n = ');  readln(n);
  randomize;
  writeln('исходный массив:');
  for i:=1 to n do
  begin
    a[i]:=random(100)-50;
    write(a[i],' ');
  end;
  writeln;
  writeln('новый массив:');
  for i:=1 to n div 2 do
  begin
    k:=a[i];
    a[i]:=a[n-i+1];
    a[n-i+1]:=k;
  end;
  for i:=1 to n do write(a[i],' ');
end.

n = 10
исходный массив:
45 -29 -25 12 -38 5 15 16 47 -36
новый массив:
-36 47 16 15 5 -38 12 -25 -29 45
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?