Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Diana120000
25.03.2023 10:16 •
Информатика
Написать программу на паскале! написать программу для решения следующей : вычислить сумму объёмов и сумму полных поверхностей трёх круглых конусов,если для каждого конуса известны высота и радиус основания.использовать подпрограмму-функцию.
Ответ:
14Dana14
20.08.2020 17:58
Function V(h,r:real):real;
Begin
result:=1/3*Pi*r*r*h // ABC, ABC.net
// V:=1/3*Pi*r*r*h // Turbo, Free
End;
Function SPP(h,r:real):real;
Begin
result:=Pi*r*(R+Sqrt(r*r+h*h));
End;
Var
h,r,V0,S,SumS,SumV:real;
Begin
Write('h1 = ');ReadLn(h);
Write('r1 = ');ReadLn(r);
V0:=V(h,r);
SumV:=V0;
S:=SPP(h,r);
SumS:=S;
WriteLn('V1 = ',V0);
WriteLn('S1 = ',S);
WriteLn;
Write('h2 = ');ReadLn(h);
Write('r2 = ');ReadLn(r);
V0:=V(h,r);
SumV:=SumV+V0;
S:=SPP(h,r);
SumS:=SumS+S;
WriteLn('V2 = ',V0);
WriteLn('S2 = ',S);
WriteLn;
Write('h3 = ');ReadLn(h);
Write('r3 = ');ReadLn(r);
V0:=V(h,r);
SumV:=SumV+V0;
S:=SPP(h,r);
SumS:=SumS+S;
WriteLn('V3 = ',V0);
WriteLn('S3 = ',S);
WriteLn;
WriteLn('Sum V = ',SumV);
WriteLn('Sum S = ',SumS);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
alisa0901
02.06.2022 12:18
Запиши данное число в двоичной восьмеричной и шестнадцатеричной системе счисления...
даша3646
12.05.2023 18:45
Какие действия могут быть выполнены на слайдами...
даша3635
13.10.2020 01:21
решить.2.По данному алгоритму составьте блок схемуПример программного кода: count:=10; sum:=10; while sum 100 do begin sum:=sum+56; count:=count-1;...
Brokenheart94
19.01.2020 11:19
Переведите 6B 1) 105 2) 107 3) 106...
LEXSUS18
01.09.2020 09:48
Сұрақтарга жауап берейік 1. Робототехника деген не?2. Адам тәріздес роботтар қашан жасала бастады?3. Роботтардың адам үшін қандай пайдасын білесің?...
liza4608
17.07.2020 03:09
К преимуществу векторной графики относится: A) легкий интерфейс для создания любого изображения B) обработка сложных изображений занимает время и память C) масштабирование не влияет...
elmariya
05.09.2020 02:05
Как обозначается тип данных целых чисел?O floatО OvarO intbooleanЭто обязательный вопрос....
daниил1
12.02.2020 07:01
Как записать это в виде кода Visual Basic...
maximax325
11.01.2021 07:41
Составьте программу рисования узора. Начальное положение Робота отмечено символом ◊....
MarinaFilimonova
11.05.2020 08:53
Мини сочинение на тему служебные части речи...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Begin
result:=1/3*Pi*r*r*h // ABC, ABC.net
// V:=1/3*Pi*r*r*h // Turbo, Free
End;
Function SPP(h,r:real):real;
Begin
result:=Pi*r*(R+Sqrt(r*r+h*h));
End;
Var
h,r,V0,S,SumS,SumV:real;
Begin
Write('h1 = ');ReadLn(h);
Write('r1 = ');ReadLn(r);
V0:=V(h,r);
SumV:=V0;
S:=SPP(h,r);
SumS:=S;
WriteLn('V1 = ',V0);
WriteLn('S1 = ',S);
WriteLn;
Write('h2 = ');ReadLn(h);
Write('r2 = ');ReadLn(r);
V0:=V(h,r);
SumV:=SumV+V0;
S:=SPP(h,r);
SumS:=SumS+S;
WriteLn('V2 = ',V0);
WriteLn('S2 = ',S);
WriteLn;
Write('h3 = ');ReadLn(h);
Write('r3 = ');ReadLn(r);
V0:=V(h,r);
SumV:=SumV+V0;
S:=SPP(h,r);
SumS:=SumS+S;
WriteLn('V3 = ',V0);
WriteLn('S3 = ',S);
WriteLn;
WriteLn('Sum V = ',SumV);
WriteLn('Sum S = ',SumS);
End.