В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dobryninatonya
dobryninatonya
03.12.2021 03:29 •  Информатика

1) написать программу для нахождения периметра треугольника, если стороны вещественные числа. 2) написать программу для вычисления суммы и произведения двух произвольных чисел.

Ответ:
Римская1
Римская1
06.10.2020 02:32
1)
var a,b,c:real;
begin
write('Введите три стороны треугольника: ');
readln(a,b,c);
if((a < b+c) and (b < a+c) and (c < a+b)) then write('Периметр треугольника: ',(a+b+c):9:3)
else write('Треугольник с данным сторонами не существует');
end.

2)
var a,b:real;
begin
write('Введите два числа: ');
readln(a,b);
writeln('Сумма данных чисел: ',(a+b):9:3);
write('Произведение данных чисел: ',(a*b):9:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?