Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
MedinaIsk
01.06.2020 18:37 •
Информатика
Напишите программу в дельфи которая переводит число из десятичной в факториальную систему счисления.
Ответ:
hakimullinaale
06.10.2020 02:09
Консольное приложение:
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
begin
i:=i+1;
str(k mod i,m);
f:=m+f;
k:= k div i;
end;
writeln('f = ',f);
end.
Пример:
n = 100
f = 4020
0,0
(0 оценок)
Популярные вопросы: Информатика
baburkanybekoff
28.03.2020 01:26
Определите наибольшее натуральное трехзначное число X, для которого истинно логическое выражение: (X оканчивается на 7) И НЕ (X 200)....
Сверхразимус
16.08.2022 10:57
Сотрудники отдела разработки составили запрос на покупку компьютеров и их комплектующих: — 6 ноутбуков по 55480 руб. шт.; — 3 монитора по 21830 руб. шт.; — 11 компьютерных...
Анжела1411
02.01.2022 10:06
Вариант 2 Переведите числа в десятичную систему, а затем проверьте результаты, выполнив обратные переводы: 101010,012; 135,318; 4CA,6816....
НикаЛисовская
07.11.2022 09:50
Вопрос: два звуковых файла записаны с одинаковой частотой дискретизации и глубиной кодирования. информационный объем файла, записанного в стереорежиме, больше информационного...
vasyazabelin
08.01.2020 18:54
Язык c++ составить программу для вычисления функции...
fbnjvtlchenko
16.04.2023 20:48
Срешением . изобразите в виде графа взаимосвязи между персонажами и различными предметами из сказки про красную шапочку. мама приготовила пирожок и горшочек с маслом....
Djəñįfəŕ
03.07.2020 20:22
Напишите программу сортировки массива выбором по возрастанию и убыванию в паскале. !...
loon1488
06.07.2020 12:17
По каналу связи сообщения, содержащие только 4 буквы: с, л, о, н; для передачи используется двоичный код, до пускающий однозначное де кодирование. для букв с, о, н...
nikolayy220502
06.07.2020 12:17
Какое число является логическим продолжением ряда 18,10,6,4...
Сиронарк
25.12.2022 15:44
Рабочий выполняет некоторую работу за 5 часов.на сколько процентов он должен увеличить производительность своего труда,чтобы ту же самую работу выполнить за 4 часа?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
begin
i:=i+1;
str(k mod i,m);
f:=m+f;
k:= k div i;
end;
writeln('f = ',f);
end.
Пример:
n = 100
f = 4020