В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nik1716
nik1716
12.12.2021 11:24 •  Информатика

Составить программу для определения непринадлежности точки к отрезку.

Ответ:
Артем14698752269
Артем14698752269
06.10.2020 01:58
X1, y1 - начло отрезка
x2, y2 - конец отрезка
x0, y0 - координаты точки принадлежность которой мы будем проверять

Вывод будет True, если принадлежит, False, если не принадлежит.

Программа:

program fff;
const   _Eps: Real = 1e-3;
var  x0, y0, x1, y1, x2, y2 : real;  tmp : boolean;  begin
  readln(x1, y1);  readln(x2, y2);    readln(x0, y0);    tmp := ((x0 - x1) * (y2 - y1) - (y0 - y1) * (x2 - x1)) <= _Eps;  tmp := tmp and ( ((x1 < x0) and (x0 < x2)) or ((x2 < x0) and (x0 < x1)) );    write(tmp);  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?