Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
lipa2907
24.10.2022 00:51 •
Информатика
1.написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1. 2.вывести их произведение и сумму. программа с++. 50 .
Ответ:
BlockStriker1
06.10.2020 01:51
1.
#include <iostream>
using namespace std;
int main()
{
int a, b;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
cout << i << " ";
}
return 0;
}
Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12
2.
#include <iostream>
using namespace std;
int main()
{
int a, b, s=0;
long long p=1;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
p = p*i;
s = s+i;
}
cout << "p = " << p << " s = " << s;
return 0;
}
Пример:
a = 5
b = 12
p = 19958400 s = 68
0,0
(0 оценок)
Популярные вопросы: Информатика
dimas1410
05.04.2020 19:17
за решение логические схемы !...
archakova65
13.01.2020 08:03
Напишите в паскале программу для вычисления y = 3.24 - x^2 +23x / 12 - x (разделить 23 x на 12 - х) заранее большое желательно прикрепить файл с написанной программой...
vaneevartem625
01.01.2023 14:07
Почему в ворде и в блокноте одно и тоже сообщение весит по-разному?...
pactuwka2
01.01.2023 14:07
Записать алгоритм поменять стержень в ручке...
daha77
28.11.2021 09:04
Сравните правила техники безопасности в кабинете информатмки и в других кабинетах ( например)...
fgtsjdu
22.01.2021 04:35
Сделать открытку в word. на информатику...
J980
22.01.2021 04:35
Дополни схему виды информации по восприятия...
MaxineCaulfield2003
10.04.2020 23:18
Задание 1 Дан логотип. Выбери правильный ответ. 7.PNG графический редактор текстовой редактор электронная таблица редактор презентаций Задание 2 Выбери ответы. 1) 4.PNG...
Mimi67392
11.08.2022 04:07
Почему Чингисхан позволил решить участь Карашокы Каир-хану?...
nura20061
11.08.2022 04:07
O zbekiston qazilma boyliklari matn...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main()
{
int a, b;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
cout << i << " ";
}
return 0;
}
Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12
2.
#include <iostream>
using namespace std;
int main()
{
int a, b, s=0;
long long p=1;
cout << "a = ", cin >> a;
cout << "b = ", cin >> b;
for (int i=a; i<=b; i++) {
p = p*i;
s = s+i;
}
cout << "p = " << p << " s = " << s;
return 0;
}
Пример:
a = 5
b = 12
p = 19958400 s = 68