В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Pasсal abc.net , даны два натуральных числа n и m. составить программу, которая находит первое число в интервале [n; m] с наибольшим количеством делителей.

Ответ:
Alina221006
Alina221006
03.08.2020 10:58
Var
   n,m,d,k,Max,Maxk:integer;
Begin
Write('n = ');ReadLn(n);
Write('m = ');ReadLn(m);
Maxk:=0;
For n:= m downto n do
    Begin
    if n>1 then k:=2
    else k:=1;
    d:=n div 2;
    While d>1 do
       Begin
       if n mod d = 0 then k:=k+1;
       d:=d-1
       End;
    if k>=Maxk then
       Begin
       Maxk:=k;
       Max:=n;
       End;
    End;
WriteLn('Искомое число: ',Max);
WriteLn('Количество делителей этого числа: ',Maxk);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?