Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
sashdjfjfh
08.04.2023 07:32 •
Информатика
Даны два действительных числа составьте программу которая меньшее из них занимает их полусуммой а большее произведением.
Ответ:
Smile1smile
06.10.2020 01:35
#include <iostream>
int main() {
double a, b, t;
std::cin >> a >> b;
if( a > b) {
t = a;
a = a * b;
b = (t + b) / 2;
} else {
t = a;
a = (a + b) / 2;
b = t * b;
}
std::cout << a << " " << b << std::endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
darkdemonsown3mz
24.05.2020 11:22
Какой объем озу требуется для хранения текста объемом 425 страниц на каждой из страниц размещёно 32 по 64 символа в строке...
KatonAnton
17.12.2020 15:18
Составьте программу, которая меняет местами первое и последнее слово в строке беларусь ты моя синеокая...
Kubrex
17.12.2020 15:18
№1 составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными значениями. №2 составьте...
Котик1978
28.02.2022 23:35
Какая последовательность команда надо использовать для получения копии выделенного фрагмента рисунка. ...
KristinaE16
17.10.2021 10:54
Что лежит в основе создания графического дисплея?...
Роналду111111
19.08.2021 22:30
Используйте калькулятор windows для решения : дано: ip-адрес узла 192.168.200.139 исходная маска подсети 255.255.255.0 новая маска подсети 255.255.255.224 найти: сколько...
Jojo11wye
15.08.2021 17:25
Спрограммированием! дан текст процедуры: procedure max_min(a,b: real; var max, min: real); begin if a b then begin max: =a; min: =b end else begin max: =b; min: =a end;...
tatianani
04.04.2022 15:03
Выведите на экран те числа из заданного диапазона , которые делятся на 7 составьте программу в паскаль !...
nfyrb2014
02.12.2021 11:42
Определение степень окисления хрома в соединениях cro3 , cr2o3...
KidFlash1111
07.01.2020 00:19
Самосвал при перевозке груза развивает мощность 26квт. какая работа совершается им в течение 10мин?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main() {
double a, b, t;
std::cin >> a >> b;
if( a > b) {
t = a;
a = a * b;
b = (t + b) / 2;
} else {
t = a;
a = (a + b) / 2;
b = t * b;
}
std::cout << a << " " << b << std::endl;
}