В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
HanjiZ
HanjiZ
18.08.2020 13:40 •  Информатика

Напишите программу в pascal для этой : найти среднее арифметическое и сумму последовательности положительных чисел

Ответ:
tattysg
tattysg
06.10.2020 01:21
Var a, sum, i : integer; s, x : string; sa : real;
begin sum:=0; readln(s); for i:=1 to length(s) do begin x:=copy(s, i, 1); val(x, a); sum:=sum+a; end; sa:=sum/(length(s)); writeln('сумма: ', sum); writeln('среднее арифметическое: ', sa:4:2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?