В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Diana22855
Diana22855
27.01.2022 08:15 •  Информатика

Составить программу в pascal abc ! дано натуральное число 1)программа, которая находит сумму цифр этого числа 2)которая определяет, что число начинается и заканчивается одной и той же цифрой

Ответ:
Pavlo1248
Pavlo1248
06.10.2020 01:02
var a,b,n,sum: longint;
begin
read (n);  
b:= n mod 10;
while n>0 do  
begin  
if n div 10 = 0 then    
a:= n mod 10;    
sum:= sum + (n mod 10);  
n:= n div 10;  
end;  
writeln (sum);
if a = b then  write ('First digit = Last Digit')
else  
write ('First digit <> Last Digit');
end.
0,0(0 оценок)
Ответ:
aizazaliyaF
aizazaliyaF
06.10.2020 01:02
1 2 3 4 5 6 7 8 9 10 11 12 13 14 var i, sum, n, code:integer;  s:string; begin write('Введите натуральноее число: '); read(s); for i := 1 to Length(s) do begin Val(s, n, code); sum := sum + n; end; writeLn('Сумма цифр: ', sum); str(sum, s); if s[1] = s[Length(s)] then write('Число начинается и заканчивается одной цифрой ',
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?