Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
romanklimenkov
10.01.2021 02:20 •
Информатика
Вс++ составить программу нахождения числа строк матрицы а(6,6), максимальный элемент которых больше р
Ответ:
z478
20.08.2020 17:27
#include <iostream>
using namespace std;
int main() {
const int S = 6;
int matrix[S][S];
cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
for (int i = 0; i < S; i++) {
for (int j = 0; j < S; j++) {
cin >> matrix[i][j];
}
cout << endl;
}
int p;
cout << "p = ";
cin >> p;
int count = 0, max;
for (int i = 0; i < S; i++) {
max = matrix[i][0];
for (int j = 1; j < S; j++) {
if (matrix[i][j] > max) max = matrix[i][j];
}
if (max > p) count++;
}
cout << endl << "ответ: " << count;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
zvezda026
15.11.2020 01:41
написать прогу на Python. Напишите программу, считающую среднее арифметическое трех сгенерированных чисел в диапазоне от 0 до 100, а также разность удвоенной суммы первого...
eksergeeva5
15.10.2020 12:43
написать прогу на Python. Напишите программу, которая ищет наибольшее четное число среди введенных пяти чисел. Если такого не существует, выводит фразу not found...
zai4onok1988
31.01.2021 05:28
1) Для чего нужен аналоговый модем; 2) Перечислите обмена данных спутникового интернета; 3) Какой вид проводного подключения обсеивает наилучшую скорость и качество передачи...
Nnas22
11.10.2021 22:10
1) В графе каждая вершина имеет степень 3, а число ребер больше 16 но меньше 20 .Сколько вершин? 2)В графе 30 вершин и 80 ребер, каждая вершина имеет степень 5 или 6 .Сколько...
jsjdfjnids73639
08.12.2022 13:30
Решите систему уравнений на c#...
onlysvp
03.11.2021 23:02
Заполнение массива: for i:=1 to 5 do a[i]:=i*i. Чему равно a[2]+a[5]? ответ...
mi262
04.11.2020 02:12
Напишите эсс состоящие из 150 слов на тему Казахстан национальная страна при написании Используйте цитаты из различных источников 1 для первой цитаты создайте сноску2 для второй...
Ivan1128
06.03.2022 18:00
1. Дан массив a размером 10 элементов, заполненный датчиком случайных чисел. Найдите минимальный элемент массива. 2. Дан массив a размером 10 элементов, заполненный датчиком...
nasti0902003
04.11.2021 00:16
Если зеленое-синее, то черное-лиловое.Но если лиловое-не синее, то зеленое-не черное.Черное-не лиловое. Следовательно, зеленое-не синее...
tamilazhakupova
26.03.2022 15:35
ОЧЕНЬ НАДО ПОСМОТРИТЕ Из элементов массива С сформировать массив А той же размерности по правилу: если номер i элемента четный, то , если нечетный, то Аi=2Ci....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
const int S = 6;
int matrix[S][S];
cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
for (int i = 0; i < S; i++) {
for (int j = 0; j < S; j++) {
cin >> matrix[i][j];
}
cout << endl;
}
int p;
cout << "p = ";
cin >> p;
int count = 0, max;
for (int i = 0; i < S; i++) {
max = matrix[i][0];
for (int j = 1; j < S; j++) {
if (matrix[i][j] > max) max = matrix[i][j];
}
if (max > p) count++;
}
cout << endl << "ответ: " << count;
return 0;
}