В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Saens321
Saens321
19.05.2023 20:38 •  Информатика

Составить программу на языке паскаль для вычисления произведения элементов, больших (-7) в каждой строке матрицы с(8*6).

Ответ:
алла7781
алла7781
06.10.2020 00:37
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив 8x6 ***');
  var c:=MatrRandom(8,6,-99,99);
  c.Println(4); Writeln(4*c.ColCount*'-');
  Writeln('Произведения элементов, больших -7, построчно:');
  foreach var row in c.Rows do
    Writeln(row.Where(x->x>-7).Aggregate(int64(1),(p,q)->p*q));
end.

Пример
*** Исходный массив 8x6 ***
 -50   8 -15  55  91 -53
 -25  82  33  65  19 -63
  99  49 -80  84  -2  68
 -52 -63 -58  23  89  58
  81 -45 -71 -85  34  66
 -35   2  23  26 -33 -56
  74  35 -35  21  15 -77
  40  87 -11  77 -74 -65

Произведения элементов, больших -7, построчно:
40040
3341910
-55417824
118726
181764
1196
815850
267960
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?