В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
niksustokarev
niksustokarev
08.11.2020 17:49 •  Информатика

Составить программу для решения : "ввести число, обозначающее размер одной фотографии в мбайтах. определить, сколько фотографий поместится на флэш-карту объёмом 2 гбайта." язык программирования: pascal

Ответ:
veronikashvidun
veronikashvidun
06.10.2020 00:24
1. С вещественными числами

var
  k:real;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',
    Trunc(2*1024/k))
end.

Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626

2. С целыми числами

var
  k:integer;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.

Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?