Войти
Регистрация
Спроси ai-bota
В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Показать больше
Показать меньше
АртемGoloborshev
04.08.2020 11:34 •
Информатика
Напишите на языке с и с++ программу, которая бы пользователя, справшивала его имя и год рождения и вычисляла бы количество полных лет. пожвлуйста,
Ответ:
alexeyvinogradp0do9x
06.10.2020 00:14
C:
#include <stdio.h>
int main()
{
char name[10];
int year;
printf("Введите Ваше имя: ");
scanf("%s",&name);
printf("Здравствуйте, %s\n",name);
printf("Введите год рождения: ");
scanf("%d",&year);
printf("Вам %d лет\n", 2017-year);
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
C++
#include <iostream>
#include <string>
using namespace std;
int main()
{
string name;
int year;
cout << "Введите Ваше имя: ";
getline (cin, name);
cout << "Здравствуйте, " << name << endl;
cout << "Введите год рождения: ";
cin >> year;
cout << "Вам " << 2017-year << " лет" << endl;
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
0,0
(0 оценок)
Популярные вопросы: Информатика
Настька1210
01.05.2021 18:09
На айфон 6s появились пиксели и экран начал затухать что делать, телефон реакирует только на кнопки а экран чёрный, все ...
дамчок
24.10.2020 09:29
4) отдельное действие алгоритма - 3 буквы...
Балерина2017
30.08.2022 19:21
Склавиатуры вводится число. является ли оно нечетным двухзначным. если да, то написать «является» и найти произведение его цифр. иначе, написать «не является» и найти его...
Adonis12321
08.09.2022 10:08
Чему равно максимальное значение положительного числа в 16 битах при знаковом представлении?...
svr2
08.09.2022 10:08
Впоследовательности чисел найти кол-во чисел кратных 7 паскаль abc...
bykvav
09.09.2021 16:20
Скоро сдавать легкий вопрос ,но я не знаю как это правильно сделать! помгите необходимо вычислить в excel 891⋅43 . запись в ms excel выглядит следующим образом: +891+43 891×43...
kasatka0556
21.05.2021 09:37
Дано трёхзначное число. определить,стоит ли в середине цифра 3. нужно написать программу в pascal...
romchik228666
02.09.2021 20:48
Растровое изображение размером 320 на 240 объем файла 50 кбайт. найти максимум цветов в палитре...
ислам406
25.05.2023 11:28
Элемент графического интерфейса на экране монитора (11 букв)...
archakova65
11.04.2021 04:30
Написать программу которая будет считать среднее арифметическое всех четных элементов массива который автоматически, количество элементов должно быть 50,диапазон чисел от...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <stdio.h>
int main()
{
char name[10];
int year;
printf("Введите Ваше имя: ");
scanf("%s",&name);
printf("Здравствуйте, %s\n",name);
printf("Введите год рождения: ");
scanf("%d",&year);
printf("Вам %d лет\n", 2017-year);
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет
C++
#include <iostream>
#include <string>
using namespace std;
int main()
{
string name;
int year;
cout << "Введите Ваше имя: ";
getline (cin, name);
cout << "Здравствуйте, " << name << endl;
cout << "Введите год рождения: ";
cin >> year;
cout << "Вам " << 2017-year << " лет" << endl;
return 0;
}
Пример:
Введите Ваше имя: Natali
Здравствуйте, Natali
Введите год рождения: 2000
Вам 17 лет