Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
amwarawka
29.05.2023 15:09 •
Информатика
С++ написать программу, которая по введённому пользователем названию месяца будет выдавать количество дней в этом месяце.
Ответ:
01mrfrost10p0cb3m
06.10.2020 00:00
#include <iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
vera186
27.02.2023 08:33
Вторая система 1) 1101-101=? 2) 101*1101=?...
7Kamilla
07.11.2022 18:22
Що пересуває на рядок угору, вниз, ліворуч, праворуч вміст списку? А) Смуга прокручування; Б) вікно; В) папка....
Злата168
12.07.2022 21:59
Скільки разів буде виконана команда n*=i? n=7 for i in range(3,9,3): n*=i...
LuckProJeckt
01.06.2022 03:32
Установіть відповідність......
raminqedimov543
20.04.2021 07:52
Створити таблицю з використанням графіку в Ексель на тему: Професія ІТ-шник. Мета: скласти довідник професій, які можна набути в галузі інформаційних технологій, з ясувати, які...
диля1234567асем
18.10.2022 02:07
Доопрацювати гру. 1. Доповнити списки questions і answers питаннями і відповідями так, щоб їх було по п ять. 2. Запрограмувати перевірку відповіді користувача на кожне питання....
Amarcy
27.01.2023 08:31
Что может чат gpt, какие возможности, хитрости?...
Софайа
27.04.2022 10:08
Скорость передачи данных составляет 56000 бит с необходимо передать файл размером 280000 байт определите время передачи файла в секундах...
Alice5u811
25.02.2022 13:32
Составьте программу: возведение чётного числа в квадрат, а нечётного - в куб...
uspenza
25.02.2022 13:32
Программироание vba. надо написать программу, в которой есть функция . функция принимает массив . она сортирует массив (числа ) по возрастанию . после надо вывести полученный результат...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <map>
#include <string>
using namespace std;
int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}