В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
adamabiev
adamabiev
25.01.2020 20:02 •  Информатика

Составить программу, которая по сумме цифр определит делится ли число на

Ответ:
SekretKtoYa
SekretKtoYa
05.10.2020 23:57
Function Div3(n:longint):boolean;
var s:byte;
begin
s:=0;
while n>0 do 
begin 
s:=s+n mod 10; 
n:=n div 10; 
end;
if s mod 3=0 then Div3:=true
else Div3:=false;
end;

var a:longint;
begin
write('Введите a: ');
readln(a);
if Div3(a) then write('Число делится на 3')
else write('Число не делится на 3');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?