В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Огнены
Огнены
28.01.2020 11:41 •  Информатика

Написать программу на языке паскаль.с пошаговым объяснением действий. условие: дан массив из 15 элементов определить сколько элементов массива располагается между его максимальным и минимальным элементом.

Ответ:
erika20122003
erika20122003
05.10.2020 23:06
Const
   N = 15;
Var
   A:array[1..N] of integer;
   i,
   Max, Min:integer; // Тут будут храниться НОМЕРА Min и Max
Begin
Randomize;
{Заполнение и вывод массива}
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(' ',A[i])
    End;
WriteLn;
{Поиск максимума и минимума}
Max:=1;
Min:=1;
// Проверять начинаем со второго элемента,
// потому, что в первую очередь будем сравнивать с первым
// (т.к. Max = 1 и Min = 1)
For i:= 2 to N do
    Begin
    if A[i]>A[Max] then Max:=i;
    if A[i]<A[Min] then Min:=i;
    // Поскольку тут стоят знаки строго больше и строго меньше,
    // будут найдены только первый встретившийся максимум
    // и первый встретившийся минимум.
    // Если бы стояли знаки больше или равно(>=) и меньше или равно(<=),
    // то найдены были бы последние встретившиеся Max и Min
    // То есть, например, в первом случае в массиве:
    // 1 2 3 4 5 2 5 1
    // были бы найдены: Min = 1, Max = 5
    // во втором случае в том же массиве были бы найдены:
    // Min = 8, Max = 7
    End;
// Сколько элементов между пятым и первым ? - три.
// Между восьмым и седьмым ? - ноль
// Общая формула:
// Искомое кол-во элементов = |НомерМаксимума-НомерМинимума|-1
// Значение берём по модулю потому,
// что как минимальный элемент может стоять после максимального,
// так и максимальный после минимального
// То есть без модуля было бы так: 5-1-1 = 3, 7-8-1 = -2
// А с модулем так: |5-1|-1 = 3, |7-8|-1 = 0
// Формула может выдать -1 в том случае, когда минимум равен максимум,
// то есть когда все элементы массива равны.
// На этот случай можно вывести соответствующее сообщение, или просто вывести ноль.
WriteLn('Max = A[',Max,'] = ',A[Max]);
WriteLn('Min = A[',Min,'] = ',A[Min]);
i:=Abs(Max-Min)-1;
// перепишем сюда получившееся значение,
// чтобы потом ещё раз его не высчитывать
if i = -1 then WriteLn('Все элементы массива равны.')
else WriteLn('Кол-во элементов между Max и Min = ',i);
End.

Пример:
Исходный массив: 5 -2 -5 5 6 -7 7 -6 6 3 -4 6 -8 7 1
Max = A[7] = 7
Min = A[13] = -8
Кол-во элементов между Max и Min = 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?