В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Дінислам
Дінислам
11.03.2022 23:17 •  Информатика

Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности. входные данные: 11, 15, 30, 9, 0 выходные данные: 26.

Ответ:
olechkapushkareva
olechkapushkareva
05.10.2020 23:04
Решение фактически в один оператор

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqIntegerWhile(n->n<>0)
      .Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum)
end.
0,0(0 оценок)
Ответ:
Raptilla
Raptilla
05.10.2020 23:04
Var
   A:integer;
   S:real;
Begin
S:=0;
Repeat
Read(A);
if (9<Abs(A))and(Abs(A)<100)and(A mod 2 <> 0) then S:=S+A;
Until A=0;
WriteLn(S)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?