В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
81920346
81920346
28.10.2022 21:26 •  Информатика

Уровень a. напишите программу, в которой сортировка выполняется «методом камня» – самый «тяжёлый» элемент опускается в конец массива.

Ответ:
Arisha2544
Arisha2544
05.10.2020 23:03
Var a:array[1..10000] of integer;
n,i,j,k,t:integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
j:=n;
repeat
k:=j;
j:=0;
for i:=1 to k-1 do
if a[i+1]j:=i;
t:=a[i];
a[i]:=a[i+1];
a[i+1]:=t;
for t:=1 to n do
write(a[t],' ');
writeln;
end;
until j=0;
if k=n then
writeln(0); //Если перестановок не было, программа выводит только число 0. Если эта команда не нужна, можешь ее убрать
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?