В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
adeka088
adeka088
13.03.2022 14:38 •  Информатика

Написать программу на паскаль напиши программу ,которая вводит десять чисел в одномерный массив ,а затем складывает по модулю отдельно все положительные элементы этого массива ,отдельно отрицательные элементы и находит разницу между ними и выдает полученные на экран через файл

Ответ:
anayaremenco
anayaremenco
05.10.2020 22:53
Var arr: array [1..10] of integer;
var i,sum,sum1:integer;
begin
for i:=1 to 10 do begin
writeln('Введите ',i,' элемент');
readln(arr[i]);
end;
sum:=0;
sum1:=0;
for i:=1 to 10 do begin
if (arr[i]>0) then begin
sum:= sum + arr[i];
end
else
if (arr[i]<0) then begin 
sum1:= sum1 + arr[i];
end;
end;
writeln('Сумма положительных равна ',sum);
writeln('Сумма отрицательных равна ',sum1);
writeln('Разница равна ',sum-sum1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?