В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
alekshaino
alekshaino
05.01.2020 05:18 •  Информатика

Составьте программу решения квадратного уравнения, если заданы его коэффициенты в условном операторе (

Ответ:
СилаЛебедя
СилаЛебедя
05.10.2020 22:28
Program kvadrurav;
var
a:integer;
b:integer;
c:integer;
d:integer;
begin
Writeln('введите число а');
Readln(a);
Writeln('введите число b')
;Readln(b);
Writeln('введите число c');
Readln(c);
d:=b*b-(4*a*c);
if d>0 then  Writeln('x1=',(-b-Sqrt(D))/(2*a),' ','x2=',((-b+Sqrt(D))/(2*a))) ;
 if d=0 then          
Writeln('x1=',-b/(2*a))     
else     
Writeln('нет корней');
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?