В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
masha3231
masha3231
22.10.2021 07:16 •  Информатика

Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. программа получает на вход количество чисел в последовательности, а затем сами числа.в последовательности всегда имеется число, кратное 5. ко личе ство чисел не пре вы ша ет 1000. введённые числа не пре вы ша ют 30 000. пграмма должна вывести одно число — максимальное число, кратное 5.

Ответ:
Supernix
Supernix
20.08.2020 16:10

Program kratnoe;

var N,i,a,max: integer;

begin

writeln('Введите количество чисел:'); Readln(N);

max:=0;

For i:=1 to N do

begin

write('Введите число:'); readln(a);

if a mod 5 = 0 then

if a>max then max:=a;

end;

writeln('ответ:',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?