Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
АринаБелочка1803
11.01.2022 00:30 •
Информатика
Написать программу на паскале: на вход целые числа до появления нуля. вывести максимальное количес тво подряд идущих чисел, кратных 3.
Ответ:
liz041
31.08.2020 22:25
Var
x, n, max: integer;
begin
n := 0;
max := 0;
while true do
begin
read(x);
if(x mod 3 = 0)and(x<>0) then n := n + 1
else begin if(n > max) then max := n; n := 0; end;
if(x = 0) then break;
end;
write(max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
OWERpass
04.01.2023 14:04
Как из 2 системы счисления перевести в 16! на примере этого выражения 1001100110011100...
sashaaaa5
09.01.2021 13:59
Сколько компакт дисков обьёмом 700мигабайт каждый потребуется для хранения орхива,обьёмом 2 терабайта...
mickeymouse1958
01.02.2022 00:30
1чим розрізняються цілочисленні та дійсні типи даних? 2 які типи даних мови с++ призначені для подання цілих чисел? 3 які значення можуть приймати величини логічного...
seks73839
25.12.2021 14:23
Переведите числа из 10-ной системы счисления в 2-ную 85 10= 72 10= 45 10= 18 10=...
343213
01.07.2022 18:23
Нужно сделать pascal нужно посчитать количество единичных битов числа 14...
MrTraserS
01.07.2022 18:23
Чай растёт в холодных погодных условиях? или в тёплых...
TheFoxySmile
01.07.2022 18:23
Общее количество папок и ярлыков на фрагменте рабочего стола равно...
Marshmelloo
30.03.2023 13:09
Как задается точка на экране? * расстоянием от верхнего края расстоянием от левого края двумя координатами тремя координатами Как изменяется координата на экране?...
сорин8888
04.05.2020 13:00
1. возведи в квадрат 2. вычти 2 первая из них возводит число на экране во вторую степень, вторая вычитает 2. составьте алгоритм получения из числа 4 числа 142,...
Lichnosti
16.10.2022 22:13
1. раздели на 2 2. вычти 1 первая из них уменьшает число на экране в 2 раза, вторая уменьшает его на 1. исполнитель работает только с натуральными числами. составьте...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x, n, max: integer;
begin
n := 0;
max := 0;
while true do
begin
read(x);
if(x mod 3 = 0)and(x<>0) then n := n + 1
else begin if(n > max) then max := n; n := 0; end;
if(x = 0) then break;
end;
write(max);
end.