В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Iamjav
Iamjav
30.07.2020 22:25 •  Информатика

Напишите программу, которая сортирует одномерный массив. дана матрица размерами 4 на 4. заполните ее следующим образом: если сумма индексов четная – в ячейке должно содержаться произведение индексов, если сумма индексов нечетная – в ячейке должна содержаться сумма индексов.

Ответ:
rasputinasvutiknbnb
rasputinasvutiknbnb
05.10.2020 22:13
1)

Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,j:integer;
Begin
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
For j:= 1 to N do
    For i:= 1 to N-1 do
        if A[i]<A[i+1] then Swap(A[i],A[i+1]);
For i:= 1 to N do
    Write(A[i],' ');

End.

2)

Var
   A:array[1..4,1..4] of integer;
   i,j:integer;
Begin
For i:= 1 to 4 do
    Begin
    For j:= 1 to 4 do
        Begin
        if (i+j) mod 2 = 0 then A[i,j]:=i*j
        else A[i,j]:=i+j;
        Write(A[i,j],' ')
        End;
    WriteLn
    End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?