В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hramkova1983
hramkova1983
28.01.2023 06:26 •  Информатика

Синформатикой . №1 напишите программу ,которая в последовательности целых чисел определяет кол-во чисел, оканчивающихся на 5. программа получает на вход одномерный массив из 20 случайных чисел в диапазоне значений от 100 до 200. программа должна вывести одно число : кол-во чисел , оканчивающихся на 5 или вывести сообщение "таких чисел нет".ввод и вывод массива организовать при процедуры. №2 напишите программу ,которая в последовательности целых чисел определяет максимальное число ,кратное 3 .программа получает на вход двухмерный массив из 40 случайных чисел в диапазоне значений от -100 до 100. программа должна вывести одно число - максимальное число ,кратное 3 или вывести сообщение "таких чисел нет'. ввод и вывод массива организовать при процедуры.

Ответ:
anna0101rus
anna0101rus
14.08.2020 21:15
1)
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(20, 100, 200);
    Println(a);
    var k := a.Count(x -> x mod 10 = 5);
    Writeln((k = 0) ? 'Таких чисел нет' : k.ToString());
end.

2)
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(40, -100, 100);
    Println(a);
    var max := a.Count(x -> x mod 3 = 0);
    if max <> 0 then
        max := a.Where(x -> x mod 3 = 0).Max;
    Writeln((max = 0) ? 'Таких чисел нет' : max.ToString());
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?