В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aregv
aregv
28.10.2021 08:54 •  Информатика

Программа получает на вход целые числа, не равные 0. количество введенных чисел неизвестно, последовательность чисел заканчивается 0. введенные числа по модулю не превышают 30000. программа должна ответить на вопрос: верно ли, что максимальное из чисел превышает минимальное больше чем в 2 раза?

Ответ:
ichernikov21
ichernikov21
05.10.2020 22:09
Var A,Max,Min:integer;
Begin
ReadLn(A);
Max:=A;
Min:=A;
While A<>0 do
   Begin
   ReadLn(A);
   if A>Max then Max:=A;
   if A<Min then Min:=A;
   End;
WriteLn(Max/Min > 2)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?