В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kareta2004
kareta2004
18.01.2022 21:30 •  Информатика

Напишите программу : дан массив f, c - целых 30 чисел . найдите произведение положительных и отрицательных чисел.

Ответ:
LimOonka
LimOonka
05.10.2020 22:08
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    var a := ArrRandomInteger(30, -100, 100);
    Println(a);
    Writeln('Произведение положительных ', a.Where(x -> x > 0).Aggregate(1, (x, y)-> x * y));
    Writeln('Произведение отрицательных ', a.Where(x -> x < 0).Aggregate(1, (x, y)-> x * y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?