Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
bogoslowskaia
08.06.2022 02:39 •
Информатика
Составить программу c++ дана плотность жидкости и плотность тела. определить, что произойдет с некоторым телом, опущенным в жидкость. например, свинец утонет в воде, а дерево нет
Ответ:
Gaxling
05.10.2020 21:16
#include <iostream>
using namespace std;
int main() {
double p1, p2;
cout << "плотность жидкости = ", cin >> p1, cout << "\n";
cout << "плотность тела = ", cin >> p2, cout << "\n";
if (p1>p2) cout << "тело будет плавать на поверхности";
else if (p1<p2) cout << "тело уйдет на дно";
else cout << "тело будет плавать полностью погрузившись в жидкость";
return 0;
}
Пример:
плотность жидкости = 1.3
плотность тела = 11.2
тело уйдет на дно
0,0
(0 оценок)
Популярные вопросы: Информатика
asim2001
04.04.2021 04:25
1)переведите в указанные сс. 1110 = 2 2)переведите в указанные сс. 5910 = 16 3)переведите в указанные сс. 27310 = 2 4)переведите в указанные сс. 684410 = 16...
HomelessGod1
08.08.2021 15:14
По моделированию (pascal или exel). файл с таблицами прилагается (практическая номер 7). 1. парашютист массой 90 кг разгоняется в свободном падении до скорости 10 м/с и на высоте...
pinelopa2005
25.12.2022 18:04
Домашнее задание: написать конспект и ответить на вопросы 1. из чего состоят задачи проектирования БД? 2. Какие действия можно выполнить с записями БД? 3. Что такое СУБД реляционного...
TheKateClapp123
29.06.2022 18:36
УРОК ВИДЕОКОНФЕРЕНЦИЯif x 0: z = x + 5elif x = = 0: z = x + 2else: z = 1z = 1z = 5z = 7z = 10...
kashamovasha
21.06.2021 04:56
Дан фрагмент кода программы. Z — Оfor x in range(3, 7):z = x+1Сколько раз выполнится тело цикл3412...
sadernik2
23.09.2020 07:26
с информатикой Запишите программу нахождения произведения всех элементов массива M(N) сумма цифр, которых равна заданному числу Z. Сумма цифр числа должна определяться в процедуре...
Danielriisna13
01.07.2022 10:25
Глорија во рана на работното Thue nagpama zalagpama ця 5 zraigimo...
Vceohenploxo
25.01.2021 21:04
Назвать 6-7 интересных фактов о творчестве баха...
АлексейGrigorjew
25.01.2021 21:04
У трапеции MNKL одно основание в два раза больше другого, а её площадь равна 384 см ^2. Определи, какова высота данной трапеции, если она равна меньшему основанию....
123arrem
31.05.2020 05:05
Составьте квадратное уравнение с коэффицентом а=-6;с=-1;в=8...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
double p1, p2;
cout << "плотность жидкости = ", cin >> p1, cout << "\n";
cout << "плотность тела = ", cin >> p2, cout << "\n";
if (p1>p2) cout << "тело будет плавать на поверхности";
else if (p1<p2) cout << "тело уйдет на дно";
else cout << "тело будет плавать полностью погрузившись в жидкость";
return 0;
}
Пример:
плотность жидкости = 1.3
плотность тела = 11.2
тело уйдет на дно