В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Используя язык программирования pascal, написать программу, которая вычисляет следующую сумму s= (2*4)/(1+*8)/(2+3)+(10*12)/(3+*56)/(14+15) и выводит ее результат. писать нужно через цикл, желательно, с пояснением.

Ответ:
ShudrenkoArtem
ShudrenkoArtem
05.10.2020 20:50
Var i,z:integer; a,s:real;
begin
s:=0; z:=-1;
for i:=1 to 56 div 4 do
 begin
 z:=-z;
 a:=z*(i*4-2)*(i*4)/(i+i+1);
 // для наглядности:
 writeln(z,' ',i*4-2,' ',i*4,' ',i,' ',i+1);
 s:=s+a;
 end;
writeln('s = ',s);
end.

Результат:
1 2 4 1 2
-1 6 8 2 3
1 10 12 3 4
-1 14 16 4 5
1 18 20 5 6
-1 22 24 6 7
1 26 28 7 8
-1 30 32 8 9
1 34 36 9 10
-1 38 40 10 11
1 42 44 11 12
-1 46 48 12 13
1 50 52 13 14
-1 54 56 14 15
s = -54.4163713045239
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?