В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Aixerel
Aixerel
19.11.2020 10:20 •  Информатика

Напишите программу нахождения n! -произведения первых n натуральных чисел с использованием цикла с автоувеличением !

Ответ:
Ариана20021111
Ариана20021111
05.10.2020 20:33
Var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720
0,0(0 оценок)
Ответ:
Trollyz
Trollyz
05.10.2020 20:33
/* C++ 17 */

#include <iostream>
using namespace std;

int main()
{
int n, f = 1;
cout << "n = ";
cin >> n;
for (int i = 2; i <= n; i++) {
f *= i;
}
cout << f << endl;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?