В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
armanbolat98
armanbolat98
27.02.2022 04:10 •  Информатика

Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, и слово 'no', если такой пары цифр нет. примеры входные данные 212 выходные данные yes входные данные 12345 выходные данные no на паскале, .

Ответ:
repkinvasya
repkinvasya
05.10.2020 18:46
Var A:integer;
C:array[0..9] of integer;
Begin
ReadLn(A);
While A<>0 do
   Begin
   C[A mod 10]:=C[A mod 10]+1;
   A:= A div 10;
   End;
While (A<9)and(C[A]<2) do A:=A+1;
if C[A]>1 then WriteLn('YES')
else WriteLn('NO');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?