В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Artyr2017
Artyr2017
21.03.2021 06:07 •  Информатика

Написать программу, которая печатает введенное слово, начиная с последней буквы c++

Ответ:
vika16122004
vika16122004
05.10.2020 18:16
#include <iostream> 

void RevStr(char* S,int l)
{  
   char c;  
   if (l > 1)  
   {      
      c=S[0];      
      S[0]=S[l-1];      
      S[l-1]=c;      
      RevStr(S+1,l-2);    
   }
}  

int main(int argc, char* argv[])
{    
   char S[12]="Test of pen";       
   RevStr(S,11);    
   std::cout << S << std::endl;    
   return 0;
}
0,0(0 оценок)
Ответ:
TUBERSUSLIK
TUBERSUSLIK
05.10.2020 18:16
#include
#include
using namespace std;
string s;
int main ()
{
cin >> s;
reverse (s.begin(), s.end());
cout << s;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?