Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Аолвлвьвтадвлвл
19.04.2022 08:48 •
Информатика
Написать программу, которая находит минимальное из n чисел; найдите среднее арифметическое из n чисел. все на языке с++
Ответ:
agarkovr83
05.10.2020 18:10
#include<iostream>
using namespace std;
int main()
{
int N,A,M;
double S = 0;
cout << "N = ", cin >> N, cout << "\n";
cout << "Vvedite N chisel:" << endl;
cin >> A;
M = A;
S+=A;
for(int i=2; i<=N; i++)
{
cin >> A;
if (A<M) M = A;
S+= A;
}
cout << "Srednee arifm. = " << S/N << "\n";
cout << "Min = " << M << "\n";
system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Annakuznetsova2006
21.03.2023 16:37
Вначале значение переменной х равно 3. как изменится х после выполнения программы: х=5; х=-х; х=х+5...
яИзРая
10.07.2020 16:01
. Python. Определите среднее значение всех элементов последовательности, завершающейся числом О. Сам ноль в последовательность не входит, а служит как признак её окончания....
arslankutdusov
15.05.2021 23:01
III Программирование линейных алгоритмов. Урок 2 Выбери фигуру, для которой найдена длина ее контура. L1=2*pi*r L2=L1/4 3=L1-L2+2*r Рис. 1 Рис...
jezv
16.09.2020 22:22
в системе программирования pascal abc выполните проверяемое задание w3 для исполнителя робот (пройти до конца стены). стена имеет переменную длину....
ghc6
28.02.2023 10:58
РЕБЯТА КОТОРЫЙ В КРУГУ ЗАДАНИЕ СНИЗУ...
cystan98
17.08.2022 12:26
сочинение набранное на компьютере содержит 4 страницы на каждой странице 32 строк , в каждой строке 48 символов.В одном из представлений unicode каждый символ кодируется 16 битами....
StehnkaSova
18.04.2022 10:38
1101001 143 EF 143 256 256...
EdwardLab
24.03.2022 01:19
Каланчак це сило чі селогородського типу...
Alex200488005553535
18.01.2020 15:24
В равнобедренном треугольнике ABC проведена медиана BP. Угол B=70°. Найти угол А и угол С...
zokaa112
14.10.2020 08:02
Постройте гамму мажор которая имеет при ключе 5 диезов...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main()
{
int N,A,M;
double S = 0;
cout << "N = ", cin >> N, cout << "\n";
cout << "Vvedite N chisel:" << endl;
cin >> A;
M = A;
S+=A;
for(int i=2; i<=N; i++)
{
cin >> A;
if (A<M) M = A;
S+= A;
}
cout << "Srednee arifm. = " << S/N << "\n";
cout << "Min = " << M << "\n";
system("pause");
return 0;
}