Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
myster2
18.11.2022 03:56 •
Информатика
Склавиатуры вводиться трёхзначное число ,составить программу которая проверит делиться ли она на сумму своих чисел
Ответ:
Scruff17
05.10.2020 18:09
Var
A,B:integer;
Begin
WriteLn('Введите целое трёхзначное число');
ReadLn(A);
B:=(A div 100)+((A div 10) mod 10) + (A mod 10);
if (A mod B = 0) then Write(A,' делится на ',B)
else Write(A,' не делится на ',B);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
lenayun
18.09.2020 02:41
КТО ТОП ЮТУБА ЭТО ПО ИНФОРМАТИКЕЕЕ У КОГО БОЛЬШЕ ВСЕГО ПОДПИСЧИКОВ НА ЮТУБЕ...
ТаняВолк15
14.05.2020 12:00
Решить trunc(6,9) trunc(6,2) round(6,9) 20 div 6 20 mod 6 2 div 5 2 mod 5...
annykovaleva
29.04.2020 15:51
Если икс положительное число то вычислить б плюс икс ,иначе игрик плюс икс...
саша1501
29.03.2023 21:20
Синформатикой, ! 4 и 7 вопросы. легкие, но я 20...
gadzila1236
09.06.2023 03:21
ЧТо лучше Майнкрафт или Бравл Старс???...
Noora2017
20.08.2020 20:03
Как решить х=а4 б4 с2 д4 и у=а2 б2 с2 д4. наибольший общий делитель(х; у)=? наименьшое общие кратное(х; у)=?...
vlad200883
20.08.2020 20:03
Перевод текста по языку. jenny & sebastian . надо!...
gagarinken
20.08.2020 20:03
Автомобиль тормозит от 54 км/ч в течении 4с найти тормозной путь если коэффициэнт трения равен 0,5...
alena11021
20.08.2020 20:03
Втреугольнике авс угол а=45 градусов,угол с=60 градусов,ав=4.найдите сторону вс...
Starostina2018
20.08.2020 20:03
Тележку с покупками сдвигают с места, прикладывая к ней силу 14 н под углом 45 градусов к горизонту. с каким ускорением движется тележка по горизонтальному полу, если её масса...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
A,B:integer;
Begin
WriteLn('Введите целое трёхзначное число');
ReadLn(A);
B:=(A div 100)+((A div 10) mod 10) + (A mod 10);
if (A mod B = 0) then Write(A,' делится на ',B)
else Write(A,' не делится на ',B);
End.