В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nataklmnv
nataklmnv
19.05.2021 11:04 •  Информатика

Составить программу определения количества положительных и отрицательных элементов массива целых чисел.

Ответ:
emilimalaya
emilimalaya
20.08.2020 15:23
Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then kp:=kp+1;
if a[i]<0 then ko:=ko+1;
end;
writeln;
writeln('кол-во пол: ',kp);
writeln('кол-во отр: ',ko);
end.
0,0(0 оценок)
Ответ:
aannnnn
aannnnn
20.08.2020 15:23
Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then 
if a[i]<0 then ko:=ko+1;
w
w
e
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?