Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Marg06
30.04.2020 18:56 •
Информатика
Напишите программу,которая считает сумму цифр введенного числа(c++)
Ответ:
Irina1440
05.10.2020 17:27
#include <iostream>
using namespace std;
int main() {
string a;
int sum = 0;
cin >> a;
for (int i = 0; i < a.size(); i++) {
sum += (a[i] - '0');
}
cout <<sum;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
akrasnoplakhtyc
05.02.2021 14:51
1. скорость передачи данных через adsl-соединение равна 128 000 бит/c. сколько времени (в секундах) займет передача файла объёмом 500 кбайт по этому каналу? 2. скорость...
Alidisa1202
12.04.2022 21:49
Определите значение переменной a . полное решение, ....
adochka777
16.01.2020 20:35
Напишите программу которая вводит арифметическое выражение без скобок и операции с деревом вынести в отдельный модуль...
kseniy20001
23.10.2022 09:29
Подскажите, где ошибка: program mas2; const n=5; type mas=array[1..n]of real; var sr,sum: real; i: integer; x: mas; procedure vvod_rand(var a: mas; n: integer); var...
Ерс01
06.06.2020 18:31
Округлить десятичные дроби : 1) 7,3605 , 0,9421 , 3,1502 , 12,0374 , 9,5601 - до десятых 2) 0,67509 , 4,23265 , 29,48075 , 29,48075 - до тысячных...
nataliastatinap0147d
06.06.2020 18:31
Втреугольнике авс , сторона ав равна 16 см, сторона вс равна 16 см, а высота проведенная из вершины с равна 11 см. найти высоту проведенную к стороне вс....
Йфяалмглиоаиопр
06.06.2020 18:31
:write five questions. 1) are /you / where / going? 2) id / who / see / you / in / the street? 3) why / they / did / late / come back? 4) do / she / what / does / here?...
GylenkoSasha
06.06.2020 18:31
Игральный кубик бросают трижды. сколько элементарных исходов опыта благоприятствую событию а = {сумма очков не более 6}? можно с !...
Kamilamar
06.06.2020 18:31
Как называется дань ведённая княгиней ольгой&...
santa34
06.06.2020 18:31
Составьте такие словосочетания или предложение с числами 40, 90.100 чтобы можно было определить в форме какого падежа употребляется каждое из них...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
string a;
int sum = 0;
cin >> a;
for (int i = 0; i < a.size(); i++) {
sum += (a[i] - '0');
}
cout <<sum;
}