В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
LOVEe12
LOVEe12
13.12.2021 00:53 •  Информатика

Написать программу на языке паскаль, возведение числа в степень. степень вводится с клавиатуры.

Ответ:
vladskills09
vladskills09
05.10.2020 17:23
Возведение вещественного числа x в натуральную степень n (без использования стандартных функций):
var n,i:integer; x,xn:real;
begin
write('x = ');
readln(x);
write('n = ');
readln(n);
xn:=1;
for i:=1 to n do xn:=xn*x;
writeln('xn = ',xn:6:3);
end.

Пример:
x = 2
n = 5
xn = 32
0,0(0 оценок)
Ответ:
Алиса623
Алиса623
05.10.2020 17:23
Только степень вводится с клавы:
Var
P:integer;
St:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
St:=1;
For P:= 1 to P do
    St:=St*2;
WriteLn('2^',P,' = ',St);
End.

Пример:
Показатель степени(целое число) = 4
2^4 = 16

Степень и число вводится с клавы:

Var
P:integer;
St,O:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
Write('Основание степени(вещественное число) = ');ReadLn(O);
St:=1;
For P:= 1 to P do
    St:=St*O;
WriteLn(O,'^',P,' = ',St);
End.

Пример:

Показатель степени(целое число) = 3
Основание степени(вещественное число) = 2.5
2.5^3 = 15.625
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?