В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jamjamiam
jamjamiam
28.10.2022 16:09 •  Информатика

Напишите программу которая в последовательности натуральных чисел определяет среднее арифметическое чисел кратных 3 или сообщает , что таких чисел нет. программа на вход получает натуральные числа , последовательность заканчивается при вводе 0 . (pascal)

Ответ:
Романman
Романman
05.10.2020 17:12
Var
A,S,N:integer;
Begin
WriteLn('Введите числа');
S:=0;
N:=-1;

Repeat
Read(A);
if A mod 3 = 0 then
   Begin
   S:=S+A;
   N:=N+1;
   End
Until A=0;

WriteLn(S/N);
End.
0,0(0 оценок)
Ответ:
Irisha1986
Irisha1986
05.10.2020 17:12
Program n1;
var a,k,sum: integer;
begin
readln(a);
k:=0;
sum:=0;
while a<>0 do
begin
if a mod 3=0 then
begin
k:=k+1;
sum:=sum+a;
end;
readln(a);
end;
if k=0 then write('нет') else
write(sum/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?