В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Rroshok
Rroshok
05.06.2023 13:08 •  Информатика

Составьте программу, которая заполняет одномерный целочисленный массив из 100 элементов случайным образом в диапазоне от 1 до 40 , выводит заполненный массив на экран, а затем находит минимальный элемент и номер ячейки, которые после нахождения выводятся на экран

Ответ:
марина1916
марина1916
05.10.2020 17:02
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
writeln('исходный массив:');
var a:=ArrRandom(100,1,40).Println();
var k:=1;
foreach var item in a do if item=a.Min then break else inc(k);
writeln('минимальный элемент: a[',k,']=',a.Min());
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?