В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ащя
ащя
09.01.2020 13:35 •  Информатика

Составьте программу, которая заполняет одномерный целочисленный массив из 80 элементов случайным образом в диапазоне от 1 до 35, выводит заполненный массив на экран, а затем находит максимальный элемент и минимальный элемент, перемножает максимальный и минимальный элемент, выводит н6а экран полученный ответ.

Ответ:
юсик17
юсик17
05.10.2020 16:59
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(80,1,35); a.Println;
  var amin:=a.Min;
  var amax:=a.Max;
  Writeln('Минимум ',amin,', максимум ',amax,', их произведение ',amin*amax)
end.

Пример
35 15 30 3 4 15 7 28 9 16 31 28 22 33 9 19 16 17 20 11 19 30 2 34 21 10 3 21 26 9 1 11 23 27 4 22 16 13 4 15 4 31 10 25 11 13 8 14 14 33 24 14 7 26 20 6 14 32 17 30 13 21 3 35 16 20 6 31 29 23 3 4 14 6 7 24 20 13 24 9
Минимум 1, максимум 35, их произведение 35
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?