В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Trasir
Trasir
03.01.2021 11:46 •  Информатика

Составить программу для нахождения суммы всех чисел от 10 до 20 с шагом 0,8. не for

Ответ:
Начинайко
Начинайко
05.10.2020 16:59
#include <iostream>#include <stdio.h>#include <conio.h>
int main() { setlocale(LC_ALL, "");
int step = 0; double sum = 10,i = 10;
while (i < 20) { i += 0.8; sum += i; ++step; printf("\nstep is: %d\nsum is: %g",step,sum); } _getch(); return 0;}
/*Я не уверен что до конца разобрался что вам нужно ,но вроде это.Код написан на си/си++ (Вроде вам нужен на Паскале,но и тут не особо понял последний комментарий)*/
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?