В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
petrenkof1
petrenkof1
27.01.2021 03:43 •  Информатика

1) написать программу,которая формирует случайным образом массив из n целых чисел,лежащих в диапазоне от 1 до 5,после чего на экран выводится сам массив и номера элементов с первым элементом. 2)написать программу,которая вводит массив и n целых чисел и выводит на экран элементы,кратные к числу к. 3)написать программу,которая вводит массив из n вещественных чисел,а затем заменяет в нем все элементы,превышающие данное число z,этим числом.вывести на экран полученный массив и количество замен.

Ответ:
СофаСофачка
СофаСофачка
14.08.2020 19:31
Задание #1.

const
N = 10;

var
a : array[1..N] of integer;

begin

    randomize;
    for I : byte := 1 to N do
    begin 
       a[i] := random(1, 5);
       write(a[i],' ');
    end;

    for I : byte := 2 to N do
    if a[1] = a[i] then writeln(i);

end.

Задание #2.

const
K = 2;
N = 10;

var
a : array[1..N] of integer;

begin

    for I : byte := 1 to N do
    begin
       readln(a[i]);
       if a[i] mod k = 0 then write(a[i],' ');
    end;  

end.

Задание #3.

const
Z = 2;
N = 10;

var
a : array[1..N] of integer;
count : word;

begin

    count := 0; 

    for I : byte := 1 to N do
    begin
       readln(a[i]);
       if a[i] > Z then
       begin
          a[i] := Z; 
          Inc(count);
       end;
end;

      for I : byte := 1 to N do
      write(a[i],' '); 

      writeln;

      writeln(count);

 end.

Стоит на на всякий случай пояснить, что N, K, Z - константы, их можно легко поменять, так гораздо удобнее работать с программой, если нужно что-то поменять. Процедура Inc( ) - прибавляет единицу, это короче чем писать Count := Count + 1;  В первом задание в цикле, который ищет значение элементов массива, которые равны первому элементу массива, я начал со второго элемента. потому что очевидно, что первый элемент будет равен самому себе. Надеюсь, вам написанные мной программы, она не сложные, вам стоит внимательно их просмотреть и, вы сможете без труда их понять самостоятельно, если пожелаете, разумеется.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?