В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
romanklimenkov
romanklimenkov
16.03.2022 18:56 •  Информатика

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел. входные данные входная строка содержит 5 целых чисел, разделённых пробелами. выходные данные в первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное. примеры входные данные 1 2 3 4 5 выходные данные 1 5

Ответ:
Eclipse2345
Eclipse2345
14.08.2020 19:26
#include <iostream>#include <stdio.h>#include <conio.h>
int main() { setlocale(LC_ALL, "");
int arr[5];
for (int i = 0; i < 5; ++i) { std::cout << "Введите число:"; std::cin >> arr[i]; }
int min = arr[0], max = min;
for (int i = 0; i < 5; ++i) { if (arr[i] < min) min = arr[i]; if (arr[i] > max) max = arr[i]; }
std::cout << min << "\n" << max; _getch(); return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?