В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Zzzzzzzzz1111
Zzzzzzzzz1111
11.05.2022 08:00 •  Информатика

Напишите программу,выводящую на экран все отрицательные числа из диапазона (m; n)

Ответ:
Закфаныалға
Закфаныалға
14.08.2020 19:22
Var m,n,k,i:integer;
begin
write('m, n: ');
readln(m,n);
if n<m then begin k:=m; m:=n; n:=k; end;
if m>=0
 then writeln('В диапазоне [',m,',',n,'] нет отрицательных чисел')
 else if n>0 then for i:=m to -1 do write(i,' ')
             else for i:=m to n do write(i,' ');
end.

Пример:
m, n: -5 2
-5 -4 -3 -2 -1 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?