В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
полина2125
полина2125
27.04.2021 22:10 •  Информатика

Напишите программу на c++, которая вычисляет значение выражения: y=1+2^2+3^3++n^n (n вводится пользователем)

Ответ:
tokio3
tokio3
05.10.2020 16:03
//MV C++ 2010
#include <iostream>
#include <cmath>
using namespace std;

long double forpow(int n)
{
double i;
long double rez=0;
  for (i=1; i<=n; i++) rez+=pow(i, i);
return rez;
}

int main()
{
  int a;
  cin >>a;
  cout<<forpow(a);
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?