В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kkazyna
kkazyna
19.03.2021 09:56 •  Информатика

С++ нужно написать программу которая бы распознавала наличие определённого символа в строке, например точка, если да то вывести ответ да если нет-нет. попробовал написать таким образом но оно не работает: #include using namespace std; int main(int argc, char** argv) { setlocale (lc_ctype, "russian"); char string[5]; cout< < "vveidte stroku"; gets(string); if(string==".") cout< < "da"; else cout< < "no"; system("pause"); return 0; }

Ответ:
vovamakarevich
vovamakarevich
05.10.2020 15:58
#include <iostream>
using namespace std;

int main(int argc, char** argv) 
{
setlocale (LC_CTYPE, "Russian"); 
string s;
int n=0;
cout<<"vveidte stroku\n";
getline (cin, s);
n = s.find(".");
if(n>=0)
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}

Пример:
vveidte stroku
если да то вывести ответ да если нет-нет.
da
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?