В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Kerbenbaeva2003
Kerbenbaeva2003
09.07.2021 08:15 •  Информатика

Даны два целых числа a и b. напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b входные данные: в первой строке вводятся два целых числа a и b (a< =b, a,b не больше 100 по модулю) выходные данные: программа должна вывести одно число - среднее арифметическое квадратов всех целых чисел от a до b (c 2 знаками после запятой) в c++

Ответ:
hkodzoeva
hkodzoeva
31.08.2020 20:49
#include <iostream>

using namespace std;

int main()
{
    int a,b,n = 0;
    float S = 0;
    cin >> a;
    cin >> b;
    
    for(int i = a; i <= b; i++)
    {
         n++;
         S+=i*i;
    }
    S = S/n;
    cout.setf(ios::fixed);
    cout.precision(2);
    cout << "S = " << S << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?