В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lizka22855
Lizka22855
18.05.2022 14:03 •  Информатика

С++ написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. посчитать среднее арифметическое чисел которые больше 10. (использовать цикл for)

Ответ:
spaceman666
spaceman666
05.10.2020 15:25
#include <ctime>
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
srand(time(NULL));
int a[10];
int k,sum=0;
cout<<"исходные числа:"<<endl;
for(int i=0;i<10;i++)
{
a[i]=rand() % 36 - 5;
cout<<a[i]<<' ';
if (a[i]>10)
{
k=k+1;
sum=sum+a[i];
}
}
cout<<""<<endl;
cout<<"ср. арифм: "<<sum/k<<endl;
return 0;
}
0,0(0 оценок)
Ответ:
12345678йцуке
12345678йцуке
05.10.2020 15:25
#include <iostream>
#include <random>
#include <ctime>

using namespace std;

int main() {
    int sum = 0;
    int cnt = 0;
    srand(time(0));
    cout << "Numbers: ";
    for (int i = 0; i < 10; i++) {
        int a = rand() % 36 - 5;
        cout << a << " ";
        if (a > 10) {
            cnt++;
            sum += a;
        }
    }
    cout << "\nAverage value = " << (double) sum / cnt;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?